0x650cd729 relies on unsafe/foreign
0x650cd729029c76d9f6151ee977dc0ae8
Addresses and mailboxes. An address is local@domain, a dot-atom (RFC
Anonymous package: import it by hash.
- Published
- 2026-10-07
- Size
- 179,560 bytes, 14 files
- License
- MIT (LICENSE)
- Declarations
- 0 laws (0 proved), 492 defs, 29 types
Import
import 0x650cd729029c76d9f6151ee977dc0ae8/addr.bend as Addr import 0x650cd729029c76d9f6151ee977dc0ae8/core.bend as Core import 0x650cd729029c76d9f6151ee977dc0ae8/dkim.bend as Dkim import 0x650cd729029c76d9f6151ee977dc0ae8/idna.bend as Idna import 0x650cd729029c76d9f6151ee977dc0ae8/md5.bend as Md5 import 0x650cd729029c76d9f6151ee977dc0ae8/mime.bend as Mime import 0x650cd729029c76d9f6151ee977dc0ae8/net.bend as Net import 0x650cd729029c76d9f6151ee977dc0ae8/reply.bend as Reply import 0x650cd729029c76d9f6151ee977dc0ae8/send.bend as Send import 0x650cd729029c76d9f6151ee977dc0ae8/smtp.bend as Smtp import 0x650cd729029c76d9f6151ee977dc0ae8/text.bend as Text
Modules
- addr.bend 46 declarations — Addresses and mailboxes. An address is local@domain, a dot-atom (RFC
- core.bend 171 declarations — The pure core of the SMTP client: the message, the options, the
- dkim.bend 32 declarations — DKIM signing (RFC 6376; Ed25519 by RFC 8463): the header fields and
- idna.bend 26 declarations — Punycode (RFC 3492) and A-labels (RFC 5890): a domain with non-ASCII
- md5.bend 25 declarations — MD5 (RFC 1321) and HMAC-MD5 (RFC 2104), for AUTH CRAM-MD5 (RFC 2195)
- mime.bend 74 declarations — MIME and message format: UTF-8 bytes, base64 (RFC 4648), the Date
- net.bend 14 declarations — Net: connections that may turn TLS mid-stream (net.c, native only).
- reply.bend 21 declarations — Replies: a server answers each command with one or more lines, each a
- send.bend 72 declarations — Send mail over SMTP.
- smtp.bend 72 declarations — SMTP client (RFC 5321), with STARTTLS (RFC 3207), implicit TLS (RFC
- text.bend 12 declarations — Text: lines out of a byte stream, and header-safe strings. SMTP is a
Other files
Dependencies
No imports from other hub packages.
Dependents
No package in this build imports it.
Status on bend 2.0.36
| File | Status | Checker says | Time |
|---|---|---|---|
| addr.bend | checks | ALL PROOFS CHECK | 1.4 s |
| core.bend | checks | ALL PROOFS CHECK | 1.8 s |
| dkim.bend | checks | ALL PROOFS CHECK | 1.9 s |
| idna.bend | checks | ALL PROOFS CHECK | 0.9 s |
| md5.bend | checks | ALL PROOFS CHECK | 0.6 s |
| mime.bend | checks | ALL PROOFS CHECK | 1.3 s |
| net.bend | relies on unsafe/foreign | 14 defs rely on unsafe or foreign code defs: Net.connect, Net.tls, Net.connect_via, Net.tls_accept, Net.send, Net.poll, Net.close, Net.time, Net.helo, Net.hostname, Net.debug, Dkim.sha256, Dkim.alg, Dkim.signoutputSOME PROOFS FAIL Error: 14 defs rely on unsafe or foreign code: - Net.connect - Net.tls - Net.connect_via - Net.tls_accept - Net.send - Net.poll - Net.close - Net.time - Net.helo - Net.hostname - Net.debug - Dkim.sha256 - Dkim.alg - Dkim.sign | 0.7 s |
| reply.bend | checks | ALL PROOFS CHECK | 0.9 s |
| send.bend | relies on unsafe/foreign | 89 defs rely on unsafe or foreign code defs: 0x650cd729029c76d9f6151ee977dc0ae8/net.Net.connect, 0x650cd729029c76d9f6151ee977dc0ae8/net.Net.tls, 0x650cd729029c76d9f6151ee977dc0ae8/net.Net.connect_via, 0x650cd729029c76d9f6151ee977dc0ae8/net.Net.tls_accept, 0x650cd729029c76d9f6151ee977dc0ae8/net.Net.send, 0x650cd729029c76d9f6151ee977dc0ae8/net.Net.poll, 0x650cd729029c76d9f6151ee977dc0ae8/net.Net.close, 0x650cd729029c76d9f6151ee977dc0ae8/net.Net.time, 0x650cd729029c76d9f6151ee977dc0ae8/net.Net.helo, 0x650cd729029c76d9f6151ee977dc0ae8/net.Net.hostname, 0x650cd729029c76d9f6151ee977dc0ae8/net.Net.debug, 0x650cd729029c76d9f6151ee977dc0ae8/net.Dkim.sha256, 0x650cd729029c76d9f6151ee977dc0ae8/net.Dkim.alg, 0x650cd729029c76d9f6151ee977dc0ae8/net.Dkim.sign, 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.drop, 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.bye.got, 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.bye.sent, 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.quit, 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.got, 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.read, 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.check, 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.expect, 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.sent, 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.send, 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.talk, 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.helo.go, 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.helo.named, 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.hello.got, 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.hello.named, 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.hello.name, 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.hello, 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.ask, 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.ask2, 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.rcpt.got, 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.rcpts, 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.reset, 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.end.got, 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.finals, 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.outcome, 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.put, 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.data.got, 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.undata.got, 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.undata, 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.empty, 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.body, 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.skip, 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.refused, 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.mail.got, 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.deliver, 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.sized, 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.utf8.ok, 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.one, 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.batch, 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.sasl.end, 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.sasl.got, 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.sasl.last, 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.sasl.at, 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.sasl, 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.cram, 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.auth.with, 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.auth, 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.login, 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.tls.done, 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.tls, 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.starttls, 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.upgrade, 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.secure, 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.greet, 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.opened, 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.connected, 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.dial.at, 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.dial, 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.sign.end, 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.sign.cut, 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.sign, 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.job.io, 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.jobs, 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.go, 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.checked, 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.send_many, 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.send_mail, Send.all, Send.go, Send.creds.ok, Send.secrets, Send.start, Send.run, Send.args, mainoutputSOME PROOFS FAIL Error: 89 defs rely on unsafe or foreign code: - 0x650cd729029c76d9f6151ee977dc0ae8/net.Net.connect - 0x650cd729029c76d9f6151ee977dc0ae8/net.Net.tls - 0x650cd729029c76d9f6151ee977dc0ae8/net.Net.connect_via - 0x650cd729029c76d9f6151ee977dc0ae8/net.Net.tls_accept - 0x650cd729029c76d9f6151ee977dc0ae8/net.Net.send - 0x650cd729029c76d9f6151ee977dc0ae8/net.Net.poll - 0x650cd729029c76d9f6151ee977dc0ae8/net.Net.close - 0x650cd729029c76d9f6151ee977dc0ae8/net.Net.time - 0x650cd729029c76d9f6151ee977dc0ae8/net.Net.helo - 0x650cd729029c76d9f6151ee977dc0ae8/net.Net.hostname - 0x650cd729029c76d9f6151ee977dc0ae8/net.Net.debug - 0x650cd729029c76d9f6151ee977dc0ae8/net.Dkim.sha256 - 0x650cd729029c76d9f6151ee977dc0ae8/net.Dkim.alg - 0x650cd729029c76d9f6151ee977dc0ae8/net.Dkim.sign - 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.drop - 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.bye.got - 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.bye.sent - 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.quit - 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.got - 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.read - 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.check - 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.expect - 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.sent - 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.send - 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.talk - 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.helo.go - 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.helo.named - 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.hello.got - 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.hello.named - 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.hello.name - 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.hello - 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.ask - 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.ask2 - 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.rcpt.got - 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.rcpts - 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.reset - 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.end.got - 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.finals - 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.outcome - 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.put - 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.data.got - 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.undata.got - 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.undata - 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.empty - 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.body - 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.skip - 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.refused - 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.mail.got - 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.deliver - 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.sized - 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.utf8.ok - 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.one - 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.batch - 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.sasl.end - 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.sasl.got - 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.sasl.last - 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.sasl.at - 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.sasl - 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.cram - 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.auth.with - 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.auth - 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.login - 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.tls.done - 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.tls - 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.starttls - 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.upgrade - 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.secure - 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.greet - 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.opened - 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.connected - 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.dial.at - 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.dial - 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.sign.end - 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.sign.cut - 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.sign - 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.job.io - 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.jobs - 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.go - 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.checked - 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.send_many - 0x650cd729029c76d9f6151ee977dc0ae8/smtp.Smtp.send_mail - Send.all - Send.go - Send.creds.ok - Send.secrets - Send.start - Send.run - Send.args - main | 3.1 s |
| smtp.bend | relies on unsafe/foreign | 81 defs rely on unsafe or foreign code defs: 0x650cd729029c76d9f6151ee977dc0ae8/net.Net.connect, 0x650cd729029c76d9f6151ee977dc0ae8/net.Net.tls, 0x650cd729029c76d9f6151ee977dc0ae8/net.Net.connect_via, 0x650cd729029c76d9f6151ee977dc0ae8/net.Net.tls_accept, 0x650cd729029c76d9f6151ee977dc0ae8/net.Net.send, 0x650cd729029c76d9f6151ee977dc0ae8/net.Net.poll, 0x650cd729029c76d9f6151ee977dc0ae8/net.Net.close, 0x650cd729029c76d9f6151ee977dc0ae8/net.Net.time, 0x650cd729029c76d9f6151ee977dc0ae8/net.Net.helo, 0x650cd729029c76d9f6151ee977dc0ae8/net.Net.hostname, 0x650cd729029c76d9f6151ee977dc0ae8/net.Net.debug, 0x650cd729029c76d9f6151ee977dc0ae8/net.Dkim.sha256, 0x650cd729029c76d9f6151ee977dc0ae8/net.Dkim.alg, 0x650cd729029c76d9f6151ee977dc0ae8/net.Dkim.sign, Smtp.drop, Smtp.bye.got, Smtp.bye.sent, Smtp.quit, Smtp.got, Smtp.read, Smtp.check, Smtp.expect, Smtp.sent, Smtp.send, Smtp.talk, Smtp.helo.go, Smtp.helo.named, Smtp.hello.got, Smtp.hello.named, Smtp.hello.name, Smtp.hello, Smtp.ask, Smtp.ask2, Smtp.rcpt.got, Smtp.rcpts, Smtp.reset, Smtp.end.got, Smtp.finals, Smtp.outcome, Smtp.put, Smtp.data.got, Smtp.undata.got, Smtp.undata, Smtp.empty, Smtp.body, Smtp.skip, Smtp.refused, Smtp.mail.got, Smtp.deliver, Smtp.sized, Smtp.utf8.ok, Smtp.one, Smtp.batch, Smtp.sasl.end, Smtp.sasl.got, Smtp.sasl.last, Smtp.sasl.at, Smtp.sasl, Smtp.cram, Smtp.auth.with, Smtp.auth, Smtp.login, Smtp.tls.done, Smtp.tls, Smtp.starttls, Smtp.upgrade, Smtp.secure, Smtp.greet, Smtp.opened, Smtp.connected, Smtp.dial.at, Smtp.dial, Smtp.sign.end, Smtp.sign.cut, Smtp.sign, Smtp.job.io, Smtp.jobs, Smtp.go, Smtp.checked, Smtp.send_many, Smtp.send_mailoutputSOME PROOFS FAIL Error: 81 defs rely on unsafe or foreign code: - 0x650cd729029c76d9f6151ee977dc0ae8/net.Net.connect - 0x650cd729029c76d9f6151ee977dc0ae8/net.Net.tls - 0x650cd729029c76d9f6151ee977dc0ae8/net.Net.connect_via - 0x650cd729029c76d9f6151ee977dc0ae8/net.Net.tls_accept - 0x650cd729029c76d9f6151ee977dc0ae8/net.Net.send - 0x650cd729029c76d9f6151ee977dc0ae8/net.Net.poll - 0x650cd729029c76d9f6151ee977dc0ae8/net.Net.close - 0x650cd729029c76d9f6151ee977dc0ae8/net.Net.time - 0x650cd729029c76d9f6151ee977dc0ae8/net.Net.helo - 0x650cd729029c76d9f6151ee977dc0ae8/net.Net.hostname - 0x650cd729029c76d9f6151ee977dc0ae8/net.Net.debug - 0x650cd729029c76d9f6151ee977dc0ae8/net.Dkim.sha256 - 0x650cd729029c76d9f6151ee977dc0ae8/net.Dkim.alg - 0x650cd729029c76d9f6151ee977dc0ae8/net.Dkim.sign - Smtp.drop - Smtp.bye.got - Smtp.bye.sent - Smtp.quit - Smtp.got - Smtp.read - Smtp.check - Smtp.expect - Smtp.sent - Smtp.send - Smtp.talk - Smtp.helo.go - Smtp.helo.named - Smtp.hello.got - Smtp.hello.named - Smtp.hello.name - Smtp.hello - Smtp.ask - Smtp.ask2 - Smtp.rcpt.got - Smtp.rcpts - Smtp.reset - Smtp.end.got - Smtp.finals - Smtp.outcome - Smtp.put - Smtp.data.got - Smtp.undata.got - Smtp.undata - Smtp.empty - Smtp.body - Smtp.skip - Smtp.refused - Smtp.mail.got - Smtp.deliver - Smtp.sized - Smtp.utf8.ok - Smtp.one - Smtp.batch - Smtp.sasl.end - Smtp.sasl.got - Smtp.sasl.last - Smtp.sasl.at - Smtp.sasl - Smtp.cram - Smtp.auth.with - Smtp.auth - Smtp.login - Smtp.tls.done - Smtp.tls - Smtp.starttls - Smtp.upgrade - Smtp.secure - Smtp.greet - Smtp.opened - Smtp.connected - Smtp.dial.at - Smtp.dial - Smtp.sign.end - Smtp.sign.cut - Smtp.sign - Smtp.job.io - Smtp.jobs - Smtp.go - Smtp.checked - Smtp.send_many - Smtp.send_mail | 3.1 s |
| text.bend | checks | ALL PROOFS CHECK | 0.8 s |